Stripe Gateway requires updates

This topic contains 2 replies, has 2 voices, and was last updated by  Laura Yates 1 month, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42186

    Event Organiser Stripe Gateway readme.txt shows the last update as being;
    == 2.2.3 – 19th September 2019 ==
    There have been a number of updates to the Stripe PHP library since then which haven’t been echoed in EO Stripe Gateway plugin.

    Could you please advise what your timeline is for updating the Stripe PHP library / Stripe Gateway plugin.

    Laura Yates
    #42209

    Hi Laura,

    The current version of the library used meets the needs of the plug-in, and I don’t think there have been any security fixes in subsequent versions that would necessitate upgrading the library (they appear to be largely code refactoring, and unrelated API changes).

    So there are no immediate plans to upgrade the library – but if you have encountered an issue you think would be resolved by upgrading then I will investigate that.

    Stephen Harris
    #42211

    With 8.1 we were getting a 500 from Stripe until the change in lib/ApiRequestor.php from the following Stripe PR was incorporated;

    https://github.com/stripe/stripe-php/pull/725/files

    Hopefully that can be included in the next update.

    • This reply was modified 1 month, 2 weeks ago by  Laura Yates.
    Laura Yates
Viewing 3 posts - 1 through 3 (of 3 total)
To enable me to focus on Pro customers, only users who have a valid license for the Pro add-on may post new topics or replies in this forum. If you have a valid license, please log-in or register an account using the e-mail address you purchased the license with. If you don't you can purchase one here. Or there's always the WordPress repository forum.