Google Maps API rejects request due to missing "sensor" parameter

WordPress Event Management, Calendars & Registration Forums Report A Bug Google Maps API rejects request due to missing "sensor" parameter

This topic contains 1 reply, has 1 voice, and was last updated by  caratage 8 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4587

    Hi all,

    I am using eo_get_venue_map('my-venue-slug',array('width'=>'852px', 'height'=>'500px')); to display the map of a specific venue.
    Everything works fine until I log out.

    The page loads with a JavaScript alert: The Google Maps API server rejected your request. The "sensor" parameter specified in the request must be set to either "true" or "false".
    Seems that the parameters for Google Maps are missing as logged out users get the above alert and the script tag reads http://maps.googleapis.com/maps/api/js

    For logged in users, the map shows and the script tag reads http://maps.googleapis.com/maps/api/js?sensor=false&callback=eo_load_map&language=en&ver=3.5.1

    Any ideas?

    caratage
    #4588

    Uh oh! It was a plugin interference.

    I have Better WP Security installed and there is an option that deals with version numbers as in the above string: “Displays a random version number to visitors who are not logged in at all points where version number must be used and removes the version completely from where it can. Warning: This feature is known to cause conflicts with some plugins and themes.”

    I disabled the option and now all is working again.
    closed

    caratage
Viewing 2 posts - 1 through 2 (of 2 total)
To enable me to focus on Pro customers, only users who have a valid license for the Pro add-on may post new topics or replies in this forum. If you have a valid license, please log-in or register an account using the e-mail address you purchased the license with. If you don't you can purchase one here. Or there's always the WordPress repository forum.