Google Calendar is empty when subscribing

WordPress Event Management, Calendars & Registration Forums Report A Bug Google Calendar is empty when subscribing

This topic contains 1 reply, has 2 voices, and was last updated by  Stephen Harris 2 weeks, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #32172

    I have added this shortcode to my site, so members of the site can subscribe to the calendar:

    [eo_subscribe class=”button” title=”Abonneer op agenda” type=”webcal”] Outlook [/eo_subscribe]

    [eo_subscribe class=”button” title=”Abonneer op agenda” type=”ical”] Apple Calendar

    [/eo_subscribe] [eo_subscribe class=”button” title=”Abonneer op agenda” type=”Google”] Google Agenda [/eo_subscribe]

    As you can see, the links that are generated by the ‘webcal’ and ‘ical’ shortcodes work perfectly well, but when a user clicks on the ‘google’ link in the frontend, the calendar that is added to Google is completely empty. Also, in the URL I can see that it refers to a http rather than an https URL.

    Could you please look into this / resolve this?

    Many thanks, René

    René Vlak
    #32224

    Hi Rene,

    It is because for logged-out users, you are redirected to a log-in page. When Google is fetching the events, the log-in page, rather than the event feed is being returned.

    Stephen Harris
Viewing 2 posts - 1 through 2 (of 2 total)
To enable me to focus on Pro customers, only users who have a valid license for the Pro add-on may post new topics or replies in this forum. If you have a valid license, please log-in or register an account using the e-mail address you purchased the license with. If you don't you can purchase one here. Or there's always the WordPress repository forum.