Error on PHP Compatibility Checker

WordPress Event Management, Calendars & Registration Forums Report A Bug Error on PHP Compatibility Checker

This topic contains 1 reply, has 2 voices, and was last updated by  Stephen Harris 1 month, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42187

    Hi – I ran the PHP Compatibility Checker and the following two errors came up:

    <h2>FOUND 2 ERRORS AFFECTING 2 LINES</h2>

    156 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    541 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead

    The site is currently on PHP 7.3 and the Events plugin is up to date.

    I don’t want to do the PHP update with these errors reported – please could you advise?

    Many thanks.
    Susie

    Susie Brew
    #42188

    Hi Susie,

    The errors indicated in this instance are false positives – the plug-in has found a code path which is not executed on more up-to-date configurations, and exists only as backwards support for those running older PHP versions.

    Event Organiser has been tested against PHP 7 and PHP 8.

    Stephen Harris
Viewing 2 posts - 1 through 2 (of 2 total)
To enable me to focus on Pro customers, only users who have a valid license for the Pro add-on may post new topics or replies in this forum. If you have a valid license, please log-in or register an account using the e-mail address you purchased the license with. If you don't you can purchase one here. Or there's always the WordPress repository forum.