Booking Export – Fields Not Matching

WordPress Event Management, Calendars & Registration Forums Report A Bug Booking Export – Fields Not Matching

This topic contains 1 reply, has 1 voice, and was last updated by  Chris Dunst 1 month, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43970

    Hi Stephen, a client of ours runs football coaching sessions for kids. They have a few different booking forms, for different event types (week camps, evening camps etc). These booking forms have unique fields, but some crossover – i.e. ‘Child Name’ is on each form.

    When running a bookings export, we’re presented with the whole list of custom booking form fields, from across all forms, so they have multiple ‘Child Name’ fields to choose from for instance. They don’t know which one is needed for that given event, so have to select all checkboxes.

    The CSV output gives a column for all of these duplicates. This wouldn’t be too bad – they could delete empty columns – but unfortunately the data columns are bunched up, whereas column headers have a column of their own. The upshot is, the data doesn’t align properly with the column headers.

    The ideal solution would be an option to e.g. ‘select all custom fields for this event’ and it returns just the fields, pertaining to the booking form, pertaining to the event being exported. This would save having to manually tick all custom field boxes.

    Next best solution – have a dropdown of booking forms to select from, and it returns the fields from just that form.

    Quickest solution – if there’s a bug where ’empty’ cells aren’t being outputted for fields where there is no data, and that can be fixed, the client can easily just delete unneeded columns, but can have confidence the data is aligning with the correct header.

    Hope that makes sense? Happy to pick up over email, or supply a sample CSV.

    Don’t mean to drop a difficult one on you, just reporting back in the spirit of helpfulness.

    Thanks,
    Chris

    Chris Dunst
    #44002

    Hi Stephen, ignore this, we figured it out. A couple of the form input labels had commas in them, which threw out the csv alignment. All sorted now.

    Chris Dunst
Viewing 2 posts - 1 through 2 (of 2 total)
To enable me to focus on Pro customers, only users who have a valid license for the Pro add-on may post new topics or replies in this forum. If you have a valid license, please log-in or register an account using the e-mail address you purchased the license with. If you don't you can purchase one here. Or there's always the WordPress repository forum.