An Unknown Error Has Occurred

This topic contains 0 replies, has 1 voice, and was last updated by  Stephen Muffatti 2 weeks, 4 days ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #42045

    Hey, I have a google calendar feed that works perfectly fine only localhost but when I try and run the feed on my live site, hosted with wp-engine I get “an unknown error has occurred”

    Going through the error logs I get this:

    PHP Fatal error: Uncaught ValueError: array_combine(): Argument #1 ($keys) and argument #2 ($values) must have the same number of elements in /nas/content/live/kingswoodoxfor/wp-content/plugins/event-organiser/includes/event.php:381\nStack trace:\n#0 /nas/content/live/kingswoodoxfor/wp-content/plugins/event-organiser/includes/event.php(381): array_combine(Array, Array)\n#1 /nas/content/live/kingswoodoxfor/wp-content/plugins/event-organiser/includes/event.php(114): _eventorganiser_insert_occurrences(26430, Array)\n#2 /nas/content/live/kingswoodoxfor/wp-content/plugins/event-organiser-ical-sync/ical-functions.php(426): eo_update_event(26430, Array, Array)\n#3 /nas/content/live/kingswoodoxfor/wp-content/plugins/event-organiser-ical-sync/event-organiser-ical-sync.php(590): eo_fetch_feed(26429)\n#4 /nas/content/live/kingswoodoxfor/wp-includes/class-wp-hook.php(307): EO_Sync_Ical->ajax_fetch_feed(”)\n#5 /nas/content/live/kingswoodoxfor/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(”, Array)\n#6 /nas/content/live/kingswoodoxfor/wp-includes/plugin.php(476): WP_Hook->do_action(Array)\n#7 /nas/content/live/kingswoodoxfor/wp-admin/admin-ajax.php(187): do_action(‘wp_ajax_fetch-e…’)\n#8 {main}\n thrown in /nas/content/live/kingswoodoxfor/wp-content/plugins/event-organiser/includes/event.php on line 381, referer: https://kingswoodoxfor.wpengine.com/wp-admin/options-general.php?page=event-settings&tab=imexport

    which is odd because the code is identical as well as the feed so it must be something to do with the server?

    Stephen Muffatti
Viewing 1 post (of 1 total)
To enable me to focus on Pro customers, only users who have a valid license for the Pro add-on may post new topics or replies in this forum. If you have a valid license, please log-in or register an account using the e-mail address you purchased the license with. If you don't you can purchase one here. Or there's always the WordPress repository forum.